Deviant Login Shop  Join deviantART for FREE Take the Tour
Group Info Group Founded 5 Years ago Statistics 361 Members
56,082 Pageviews588 Watchers

Deviants

Affiliates

:icon24bps: 24bps Serving the devious

Visitors

You're not here because you're not logged in

Bug reporting

:megaphone: Found a bug in SuperdAmn? Send the group a note, and our team will try to help you!
As many of you may have realized by now, Chrome on Windows no longer allows you to install any extensions from outside of the Chrome Web Store. SuperdAmn, like virtually all userscripts, are absent from the store and in order to put up your own extensions in the Web Store you need to pay. However, there's another way to get SuperdAmn working, and for that matter, any other userscript in Chrome on Windows.

Tampermonkey is an extension that manages your userscripts for you. It also makes many userscripts that normally only work with Firefox (through Greasemonkey) work in Chrome. Using Tampermonkey, you can bypass the limitations on installing userscripts outside the Chrome Web Store. Once you have Tampermonkey, all you have to do to install SuperdAmn is click a link to it and click the "Install" button on the page that comes up. You no longer have to go through the instructions in the old Chrome installation guide.

The links for both Tampermonkey and SuperdAmn for Chrome are below:

:pointr::pointr:Click here to install TamperMonkey:pointl::pointl:
:pointr::pointr:Click here to install SuperdAmn for Chrome:pointl::pointl:
More Journal Entries

Comments


Add a Comment:
 
:iconbloodmoons:
BloodMoons Featured By Owner Jun 25, 2014   General Artist
excuse me, I am having trouble logging onto the chat. I downloaded the superdAmn 1.0.4 and it still wont let get in the chat.

There is a pop-up that keeps coming up saying things have failed and other confusing things about that chatroom x.x Can someone please help? :(

I've also been offline from dA for quite some time because of life so idk what's happened. :(
Reply
:icondeviant-garde:
deviant-garde Featured By Owner Jul 14, 2014
I know I'm late here, but make sure you have NO OTHER DAMN-RELATED USERSCRIPTS installed. It's likely that every single one of them is broken and you need to go complain to their maintainers to fix them. I outlined the crux of the fix in programming terms in my journal on the SuperdAmn 1.0.3 update.
Reply
:iconendorell-taelos:
Endorell-Taelos Featured By Owner Jun 20, 2014   General Artist
I think the recent Firefox update removed mostly all my scripts including SuperdAmn and I cannot seem to be able to install SuperdAmn again, the links just go to pages where all the text of the script code is.   Is there anyway to fix this? :B thanks!
Reply
:iconpickley:
Pickley Featured By Owner Jun 24, 2014  Professional Artist
You'll need to ensure you have Greasemonkey installed.
Reply
:iconendorell-taelos:
Endorell-Taelos Featured By Owner Jun 25, 2014   General Artist
Oh yes. I managed to fix the problem the other day by reinstalling Greasemonkey. :lol: 
Reply
:iconautumnstarr:
Autumnstarr Featured By Owner Jun 15, 2014  Hobbyist Writer
So I am not the only one pissed off at Google for ruining dAmn, this includes Autojoin AND the dAmn.ws scripts as well. If anyone can get hold of electricjonny to inform them that Chrome requires it to be part of the webstore.
Reply
:iconelectricjonny:
electricjonny Featured By Owner Jun 15, 2014  Hobbyist Photographer
Did you mean electricnet, the person who wrote this script? ;)

And yes, google went all shitty and now requires any script/extension to be in their store.  I don't know how easily that will be to do (I believe that deviant-garde and maybe Pickley now handle this script?), but for now you can get the Tampermonkey extension chrome.google.com/webstore/det… and then load the script with that.  Basically the Tampermonkey script will be a wrapper around any unofficial scripts and let you use them, even while not in the store.  And that will work for my Autojoin script too.
Reply
:iconautumnstarr:
Autumnstarr Featured By Owner Jun 15, 2014  Hobbyist Writer
Alrighty guys I took electricjonny's advice and got Tampermonkey, everything works fine now, however, Google is now requesting {requiring is too strong a word} a USD5 dollar fee for every script or extension submitted to the CWS to make it offically from the CWS. However they say they went that 'cheap' in an effort to not just block spam and whatnot, but actually produce proper upstanding extension developers or some such.

But yes, everything is now working fine with Tampermonkey
Reply
:iconelectricjonny:
electricjonny Featured By Owner Jun 15, 2014  Hobbyist Photographer
Whoa, so google wants script/extension developers to pay 5 bucks in order to submit to the store?  I'm hoping this isn't mandatory or else Chrome's future of extensions is just doomed :o

Anywho, glad you got it working :)
Reply
(1 Reply)
:icondeviant-garde:
deviant-garde Featured By Owner Jun 15, 2014
Yes, we handle it, and from what I know so far, Tampermonkey makes it work. I was going to post a notice about this yesterday...
Reply
Add a Comment: